Skip to content
Important message: JavaScript must be enabled to use this site. Please enable JavaScript in your browser and refresh the page.

BlackBerry Desktop Software for Mac v2.4

To install BlackBerry® Desktop Software for Mac v2.4, you'll need to meet the minimum system requirements listed below.

Computer software

  • Mac OS 10.6 or later
  • iTunes 10.5.2 or later for music synchronization
  • iPhoto '08 or later to import your pictures and videos
  • An active Internet connection

BlackBerry smartphones

  • BlackBerry® Device Software 4.2 or later and a media card or built-in media storage
  • For the Wi-Fi® music sync feature: BlackBerry® 6 or later

BlackBerry PlayBook tablets

  • BlackBerry® Tablet OS or BlackBerry® PlayBook™ OS 2.0 or later